We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

tojekvfx

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • tojekvfx
    Participant

    Hello Alexander,
    Thank you for looking at the file, and when you say working fine, did the final step of running the Verge3D app called app02_test activate the puzzle to export the glTF 2.0 compatible glb file for you? That is the important step failing for me.

    When I open this example zip, then open the maya file, Verge3D -> Run App Manager, Verge3D -> Export glTF, then in chrome browser run my App called app02_test.html, yes the model shows up fine in browser. It just does not export my clean glb. Then as the next step, I merely disconnect the Red channel texture output from Specular, so that Occlusion channel is only going into Base Weight, then export, then run app. Finally the export glb puzzle activates and works.

    I did watch for messages in the output window and script editor, but there was no information, here is a screen grab. Today I will try this again with Maya Standard Surface instead.
    Thank you, Jon Tojek

    Attachments:
    You must be logged in to view attached files.
    tojekvfx
    Participant

    Yes, that all makes sense, thank you Mikhail.
    JonT

    tojekvfx
    Participant

    I was able to repeat this behavior with the simple Verge3D demo cube, only adding my ORM packed texture png format. Here is the zipped Verge3D application with Maya file (app02_test.zip). Right now the Red channel of my ORM texture is connected to both Base Weight, and Specular Weight, so the Puzzle will not export a glb file. If you disconnect from either of those aiStandard attributes, then the glb does export.

    Next I will check if it is my ORM texture, which came from Substance Painter, and was modified with Nuke.
    Jon Tojek

    Attachments:
    You must be logged in to view attached files.
    tojekvfx
    Participant

    Hello Mikhail,
    Thank you for responding, and now I understand, Alpha Mode Mask in Maya is the same as Alpha Mode Clip in some of the other packages. Honestly I wish I could use Alpha Mode Blend as you show in the Verge3D documentation, but because my chair model is trying to be light with only 8 surfaces, some that are in front and behind others it seems not possible to get each Render Order number correct to make them stack and appear correct in webGL.

    Please do say if you have any other ideas for that one.
    Sincerely, Jon Tojek

    tojekvfx
    Participant

    Thank you for that full response Xeon, very helpful. For sure your idea of exporting the textures from the two platforms and comparing them is a good one, I will try that soon. One funny thing about your attached image showing the Z-fighting in the Verge3D model scares the hell out of me. My browser does not show that at all, in fact it looks completely standard. But hey, could be a browser setting, I am using Chrome on a PC. Otherwise, yes, I agree with your other comments. I will be continuing to look into this, and now plan to concentrate on the webflow and html parts.
    Thank you, Tojek_VFX

Viewing 5 posts - 1 through 5 (of 5 total)